Beeper - Unable To Send/Receive & Start New Chats on Beeper Cloud – Incident details

All systems operational

Unable To Send/Receive & Start New Chats on Beeper Cloud

Resolved
Major outage
Started 7 months agoLasted 4 days

Affected

Connections

Major outage from 12:00 AM to 4:05 PM

iMessage

Major outage from 12:00 AM to 4:05 PM

Updates
  • Resolved
    Resolved

    iMessage and Phone Registration Are Back - Kinda
    We’re extremely sorry that the iMessage connection in Beeper has been so unreliable over the last two weeks. We knew when we started Beeper that this would not be easy. Regardless, we’re deeply aware of how painful this experience has been to those of you who came to rely on Beeper to communicate with your friends and family via iMessage.

    We've found a solution to fix and stabilize the iMessage situation for Beeper Cloud and Mini users. From our internal testing, this fix works well and has been quite reliable. Even better news - we’ve even figured out how to get phone number registration working in Beeper Mini! Your phone number will be blue again.

    Here’s the catch - you will need access to an old iPhone, Mac computer, or find a friend with a Mac. If you Have a Mac with Beeper Desktop installed - please update to the latest version (v3.90.20) then click ⚙️ → Chat Networks → iMessage → Click ‘Reconnect’ and follow the instructions. Not all macOS versions are yet supported (learn more).

    Learn more in our blog post.

    While we understand that this solution will not work for everyone, please know that we’re doing our best given the circumstances. Each time that Beeper Mini goes ‘down’ or is made to be unreliable due to interference by Apple, Beeper’s credibility takes a hit. It’s unsustainable. As much as we want to fight for what we believe is a fantastic product that really should exist, the truth is that we can’t win a cat-and-mouse game with the largest company on earth.

    Read more about the path forward.

  • Identified
    Identified

    We've found a solution to stabilize the iMessage situation for Beeper Cloud and Mini. It works well, and, in our testing, is very reliable. The only downside is that the solution requires you to have access to a Mac computer, or have a friend on Beeper with a Mac.

    Here's the backstory. When you sign into iMessage on Beeper, we need to send identification information called ‘registration data’ from a real Mac computer. We have, up until now, we been using our own fleet of Mac servers to provide this. Unfortunately, this has proven to be an easy target for Apple because thousands of Beeper users were using the same registration data.

    Registration data is used only to indicate that a Mac is available during registration. The Mac in no way is given any access to your account, or your messages.

    Tomorrow, we'll publish an update for Beeper Cloud (Mac version) that generates unique registration data just for you. This 1:1 mapping of registration data to individual user, in our testing, makes the connection very reliable. If you use Beeper Mini, you can use your Mac registration data with it as well, and Beeper Mini will start to work again. Beeper needs to periodically regenerate this data even after you've connected, roughly once per week or month, so the Mac needs to switched on regularly.

    If you do not have access to a Mac computer, but have a friend on Beeper with a Mac, you can ask them if you can use their registration data. In our testing, 10-20 iMessage users can safely use the same registration data.

    We'll also be open sourcing our full iMessage bridge, as well as the Mac code that generates registration data. If you prefer, you can choose to self-host or inspect our code.

  • Investigating
    Update

    More than 60% of Beeper Mini and Cloud users are currently unable to send or receive iMessages at this time. We’re fighting to get this fixed 🤞. In the meantime, you may see notifications or emails that a ‘new Mac’ has been added to your account. We do not use Mac servers anymore, but our bridge appears to Apple as if it were a Mac.

  • Investigating
    Investigating

    Hey all, unfortunately it looks like we're having sending and receiving issues with iMessage again. We'll keep you in the loop as we work to keep things running. Apologies for the inconvenience!